Jump to content


Photo

Selector Switch Problem


  • Please log in to reply
5 replies to this topic

#1 Devil Dog 1110

Devil Dog 1110

    RKI Member

  • Board Benefactor
  • 295 posts
  • Gender:Male
  • Location:Mississippi
  • Interests:Hunting
    Military gun collecting
    Colt Thompson's

Posted 12 December 2017 - 12:59 PM

I just received my new original Inland M2 (not over stamp) carbine and the selector switch will not stay in the forward- full auto- position.
When it does fire a short burst the selector will fall back to the semi position.
Suggestions?

Thanks
  • 0

#2 jim c 351

jim c 351

    Long Time RKI Member

  • Board Benefactor
  • 2841 posts
  • Gender:Male
  • Location:Ohio

Posted 12 December 2017 - 01:35 PM

Buy some extra "9" springs and put the longest/strongest one in the gun and make sure the spring is installed correctly.

Jim C


  • 1

#3 jl7422

jl7422

    Regular Member

  • Regular Group
  • 149 posts

Posted 12 December 2017 - 02:55 PM

+1 on Jim's comment above--easy to install the "9" spring upside down.


  • 0

#4 MG08

MG08

    RKI Member

  • Regular Group
  • 452 posts
  • Gender:Male

Posted 12 December 2017 - 06:44 PM

Either way it would be a good idea to have a set of spares, and the 9 spring is easy to lose. Dont ask how I know.  There are also some parts out there that are not "USGI" and seem to have a much lower spring tension.


  • 0

#5 Devil Dog 1110

Devil Dog 1110

    RKI Member

  • Board Benefactor
  • 295 posts
  • Gender:Male
  • Location:Mississippi
  • Interests:Hunting
    Military gun collecting
    Colt Thompson's

Posted 12 December 2017 - 08:25 PM

I checked and this rifle is missing the 9 spring.
Should be an easy fix.
  • 0

#6 DougStump

DougStump

    RKI Member

  • Regular Group
  • 324 posts
  • Gender:Male
  • Location:Shreveport, Louisiana

Posted 12 December 2017 - 08:55 PM

Are you sure it's not in "Burst" mode?  :lol:  :lol:


  • 0