Jump to content


Photo
- - - - -

M1 Doesn't Finish The Mag


  • Please log in to reply
2 replies to this topic

#1 DougStump

DougStump

    RKI Member

  • Regular Group
  • 284 posts
  • Gender:Male
  • Location:Shreveport, Louisiana

Posted 01 October 2003 - 05:54 AM

My Savage M1A1 will usally not fire off the entire mag in one burst. Short bursts are fine, but it won't empty the mag all at once. When it stops, the bolt is all the way back. If you let go of the trigger, then pull again it takes off again, but may stop after 5 - 10 rounds. I made sure I had the trigger all the way back.

I'm shooting reload ammo, but I also tried some Wolf, same trouble.

What part do I need to change?

Thanks,
Doug Stump
  • 0

#2 gijive

gijive

    Respected Member

  • Board Benefactor
  • 2429 posts
  • Gender:Male
  • Location:Illinois
  • Interests:Thompson SMG, WWII, Firearms in general.

Posted 01 October 2003 - 06:13 AM

Hi,

I would consider checking all the internal grip frame parts for wear, specifically the trip, disconnector and sear lever. I would replace these and all the springs and see if the same thing occurs.
  • 0

#3 PK.

PK.

    Technical Expert

  • Board Benefactor
  • 1567 posts
  • Gender:Male
  • Location:CO, USA
  • Interests:Full time gunsmith who loves Thompsons, 35+ years experience.

Posted 01 October 2003 - 08:06 AM

The probable cause is that your Disconnector is disengaging from the Sear Lever. This could be weak springs, worn or poorly fitted parts or just a heavy build up of grime. It could also be that your Rocker is contacting the bolt intermittently; this could be due to a worn (elongated) hole in the frame or Rocker or a worn shaft on the Pivot.
  • 0